Commit a258427f authored by jehan's avatar jehan

update cmake version requirement to 3.2

parent a91fcf58
......@@ -20,7 +20,7 @@
#
############################################################################
cmake_minimum_required(VERSION 2.8.12)
cmake_minimum_required(VERSION 3.2) #since cmake 3.2 is available as a patch for yocto Fido
set(CMAKE_MACOSX_RPATH ON) # Before cmake 3.0.0, MACOSX_RPATH was not set to ON by default - however this is no good reason to not enable it by default
......
......@@ -35,6 +35,9 @@ set(BCTOOLBOX_CXX_SOURCE_FILES
crypto/ecc.cc
)
if(CMAKE_CXX_COMPILER_ID MATCHES "Clang")
list(APPEND STRICT_OPTIONS_CXX "-x c++")
endif()
if(HAVE_EXECINFO)
list(APPEND BCTOOLBOX_CXX_SOURCE_FILES utils/exception.cc)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment