Commit 84a603db authored by Simon Morlat's avatar Simon Morlat

set version number properly on android

parent ab628a81
SUBDIRS=include src tester
EXTRA_DIST = belle-sip.spec
EXTRA_DIST = belle-sip.spec VERSION
test:
cd tester && $(MAKE) test
......
......@@ -25,7 +25,8 @@ include $(CLEAR_VARS)
LOCAL_MODULE := libbellesip
LOCAL_CFLAGS += \
-DHAVE_CONFIG_H
-DHAVE_CONFIG_H \
-DPACKAGE_VERSION=$(BELLESIP_VERSION)
LOCAL_C_INCLUDES += \
$(LOCAL_PATH)/../../externals/antlr3/runtime/C/include \
......
......@@ -56,7 +56,7 @@
#else
#ifndef PACKAGE_VERSION
#define PACKAGE_VERSION "0.0.1"
#error "PACKAGE_VERSION must be defined and equal to the VERSION file included in the belle-sip repository"
#endif
#endif
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment