Commit 958ece7b authored by Simon Morlat's avatar Simon Morlat

update for mbedtls 1.3

parent 20ac4ada
......@@ -3,10 +3,12 @@ The library written in C 89 is fully portable and can be executed on many platf
Licensing: The source code is licensed under GPLv2.
Dependencies:
- polarssl 1.3 OR mbedTLS 1.3
By default, the upstream package installs into /usr/local. Please use
'./configure --prefix' to change it
Linphone plugin is compiled if both mediastremer2 and ortp are installed
----------------------------------------------------------------------------------
Compatibility with RFC6189 - ZRTP: Media Path Key Agreement for Unicast Secure RTP
......
......@@ -34,7 +34,7 @@ fi
dnl check polarssl
AC_ARG_WITH( polarssl,
[ --with-polarssl Set prefix where polarssl can be found (ex:/usr, /usr/local)[default=PREFIX] ],
[ --with-polarssl Set prefix where polarssl or mbedTLS can be found (ex:/usr, /usr/local)[default=PREFIX] ],
[ polarssl_prefix=${withval}],[ polarssl_prefix=${prefix} ])
if test "$polarssl_prefix" != "NONE" ; then
......@@ -42,7 +42,13 @@ if test "$polarssl_prefix" != "NONE" ; then
POLARSSL_LIBS="-L${polarssl_prefix}/lib"
fi
POLARSSL_LIBS="$POLARSSL_LIBS -lpolarssl"
AC_CHECK_LIB(mbedtls, ssl_init , [POLARSSL_LIBS="$POLARSSL_LIBS -lmbedtls"],
[
AC_CHECK_LIB(polarssl, ssl_init, [POLARSSL_LIBS="$POLARSSL_LIBS -lpolarssl"],
[ AC_MSG_ERROR([Polarssl or mbedTLS library not found]) ]
)
])
AC_SUBST(POLARSSL_LIBS)
AC_SUBST(POLARSSL_CFLAGS)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment