Commit 29ce0433 authored by Diego Biurrun's avatar Diego Biurrun

The AltiVec code in libswscale no longer is under GPL.

Remove one erroneous preprocessor check for CONFIG_GPL in the AltiVec code.

Originally committed as revision 29412 to svn://svn.mplayerhq.hu/mplayer/trunk/libswscale
parent e13cca4b
......@@ -511,7 +511,7 @@ SwsFunc ff_yuv2rgb_get_func_ptr(SwsContext *c)
#if CONFIG_MLIB
t = ff_yuv2rgb_init_mlib(c);
#endif
#if HAVE_ALTIVEC && CONFIG_GPL
#if HAVE_ALTIVEC
if (c->flags & SWS_CPU_CAPS_ALTIVEC)
t = ff_yuv2rgb_init_altivec(c);
#endif
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment