Commit 2eaa3663 authored by Vittorio Giovara's avatar Vittorio Giovara Committed by Luca Barbato

avplay: enable only when SDL 1.2 is found

SDL 2 is API incompatible.
Signed-off-by: default avatarLuca Barbato <lu_zero@gentoo.org>
parent adfa53d6
......@@ -2967,11 +2967,9 @@ int main(int argc, char **argv)
}
if (!display_disable) {
#if HAVE_SDL_VIDEO_SIZE
const SDL_VideoInfo *vi = SDL_GetVideoInfo();
fs_screen_width = vi->current_w;
fs_screen_height = vi->current_h;
#endif
}
SDL_EventState(SDL_ACTIVEEVENT, SDL_IGNORE);
......
......@@ -1301,7 +1301,6 @@ HAVE_LIST="
rdtsc
sched_getaffinity
sdl
sdl_video_size
SetConsoleTextAttribute
setmode
setrlimit
......@@ -3596,8 +3595,8 @@ fi
if check_pkg_config sdl SDL_events.h SDL_PollEvent; then
check_cpp_condition SDL.h "(SDL_MAJOR_VERSION<<16 | SDL_MINOR_VERSION<<8 | SDL_PATCHLEVEL) >= 0x010201" $sdl_cflags &&
enable sdl &&
check_struct SDL.h SDL_VideoInfo current_w $sdl_cflags && enable sdl_video_size
check_cpp_condition SDL.h "(SDL_MAJOR_VERSION<<16 | SDL_MINOR_VERSION<<8 | SDL_PATCHLEVEL) < 0x010300" $sdl_cflags &&
enable sdl
fi
texi2html -version > /dev/null 2>&1 && enable texi2html || disable texi2html
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment