Commit 406ab5cc authored by Justin Ruggles's avatar Justin Ruggles

add a separate line in Makefile for E-AC-3 decoder and only compile it when

GPL is enabled. fixes building without GPL or with liba52.

Originally committed as revision 15151 to svn://svn.ffmpeg.org/ffmpeg/trunk
parent 7cabcf7d
......@@ -848,6 +848,7 @@ byteswap_h_deps="!armv4l"
# decoders / encoders
ac3_decoder_deps="gpl !liba52"
dxa_decoder_deps="zlib"
eac3_decoder_deps="gpl"
flashsv_decoder_deps="zlib"
flashsv_encoder_deps="zlib"
mlp_decoder_deps="mlp_parser"
......
......@@ -63,6 +63,7 @@ OBJS-$(CONFIG_DVDSUB_ENCODER) += dvdsubenc.o
OBJS-$(CONFIG_DVVIDEO_DECODER) += dv.o
OBJS-$(CONFIG_DVVIDEO_ENCODER) += dv.o
OBJS-$(CONFIG_DXA_DECODER) += dxa.o
OBJS-$(CONFIG_EAC3_DECODER) += eac3dec.o ac3dec.o ac3tab.o ac3dec_data.o ac3.o mdct.o fft.o
OBJS-$(CONFIG_EACMV_DECODER) += eacmv.o
OBJS-$(CONFIG_EATGV_DECODER) += eatgv.o
OBJS-$(CONFIG_EIGHTBPS_DECODER) += 8bps.o
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment