Commit 9cc440bf authored by Michael Niedermayer's avatar Michael Niedermayer
Browse files

Prevent low delay from being used with mpeg1.

Originally committed as revision 14627 to svn://svn.ffmpeg.org/ffmpeg/trunk
parent 71e9a1b8
......@@ -440,8 +440,8 @@ av_cold int MPV_encode_init(AVCodecContext *avctx)
}
if(s->flags & CODEC_FLAG_LOW_DELAY){
if (s->codec_id != CODEC_ID_MPEG2VIDEO && s->codec_id != CODEC_ID_MPEG1VIDEO){
av_log(avctx, AV_LOG_ERROR, "low delay forcing is only available for mpeg1/2\n");
if (s->codec_id != CODEC_ID_MPEG2VIDEO){
av_log(avctx, AV_LOG_ERROR, "low delay forcing is only available for mpeg2\n");
return -1;
}
if (s->max_b_frames != 0){
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment