Commit ffb068ce authored by Martin Storsjö's avatar Martin Storsjö
Browse files

configure: Don't do enable_deep_weak on disabled variables



This avoids cases where configure tries to weakly enable an item
which actually is disabled, ending up still enabling dependencies
of the item which itself is only enabled weakly.

More concretely, the h264 decoder suggests error resilience, which
is then enabled weakly (unless manually disabled). Previously,
dsputil, which is a dependency of error resilience, was enabled
even if error resilience wasn't enabled in the end.
Signed-off-by: default avatarMartin Storsjö <martin@martin.st>
parent 4d810ad2
......@@ -489,8 +489,13 @@ enable_deep(){
}
enable_deep_weak(){
do_enable_deep $*
enable_weak $*
for var; do
disabled $var && continue
pushvar var
do_enable_deep $var
popvar var
enable_weak $var
done
}
enabled(){
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment