Commit 784b04ff authored by Paul Bakker's avatar Paul Bakker
Browse files

Prepared for version 1.3.6

parent d8b0c5ef
PolarSSL ChangeLog (Sorted per branch, date)
ABI Alert: ALPN changes the ABI for the next release.
= PolarSSL 1.3 branch
= PolarSSL 1.3.6 released on 2014-04-11
Features
* Support for the ALPN SSL extension
......
......@@ -4,7 +4,7 @@
*/
/**
* @mainpage PolarSSL v1.3.5 source code documentation
* @mainpage PolarSSL v1.3.6 source code documentation
*
* This documentation describes the internal structure of PolarSSL. It was
* automatically generated from specially formatted comment blocks in
......
......@@ -28,7 +28,7 @@ DOXYFILE_ENCODING = UTF-8
# identify the project. Note that if you do not use Doxywizard you need
# to put quotes around the project name if it contains spaces.
PROJECT_NAME = "PolarSSL v1.3.5"
PROJECT_NAME = "PolarSSL v1.3.6"
# The PROJECT_NUMBER tag can be used to enter a project or revision number.
# This could be handy for archiving the generated documentation or
......
......@@ -39,16 +39,16 @@
*/
#define POLARSSL_VERSION_MAJOR 1
#define POLARSSL_VERSION_MINOR 3
#define POLARSSL_VERSION_PATCH 5
#define POLARSSL_VERSION_PATCH 6
/**
* The single version number has the following structure:
* MMNNPP00
* Major version | Minor version | Patch version
*/
#define POLARSSL_VERSION_NUMBER 0x01030500
#define POLARSSL_VERSION_STRING "1.3.5"
#define POLARSSL_VERSION_STRING_FULL "PolarSSL 1.3.5"
#define POLARSSL_VERSION_NUMBER 0x01030600
#define POLARSSL_VERSION_STRING "1.3.6"
#define POLARSSL_VERSION_STRING_FULL "PolarSSL 1.3.6"
#if defined(POLARSSL_VERSION_C)
......
......@@ -108,7 +108,7 @@ endif()
if(USE_SHARED_POLARSSL_LIBRARY)
add_library(polarssl SHARED ${src})
set_target_properties(polarssl PROPERTIES VERSION 1.3.5 SOVERSION 5)
set_target_properties(polarssl PROPERTIES VERSION 1.3.6 SOVERSION 6)
target_link_libraries(polarssl ${libs})
......
......@@ -22,9 +22,9 @@ ifdef SHARED
CFLAGS += -fPIC
endif
SONAME=libpolarssl.so.5
SONAME=libpolarssl.so.6
DLEXT=so.5
DLEXT=so.6
# OSX shared library extension:
# DLEXT=dylib
......
Check compiletime library version
check_compiletime_version:"1.3.5"
check_compiletime_version:"1.3.6"
Check runtime library version
check_runtime_version:"1.3.5"
check_runtime_version:"1.3.6"
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment