Commit c4623b29 authored by Pekka Pessi's avatar Pekka Pessi

Require glib-2.4 or newer for nua_glib support. (kv)

darcs-hash:20060417081655-65a35-bbad5ccf22d9343e63f8e1ea9b1e7059a19438ec.gz
parent a443b9f4
......@@ -275,8 +275,8 @@ if test "$with_glib" = no || test "$with_glib_dir" = "no" ; then
elif test "$with_glib_dir" = "pkg-config" ; then
PKG_CHECK_MODULES(GLIB, glib-$with_glib, [HAVE_GLIB=yes])
PKG_CHECK_MODULES(GOBJECT, gobject-$with_glib, [HAVE_GOBJECT=yes])
PKG_CHECK_MODULES(GLIB, glib-$with_glib, [HAVE_GLIB=yes], [HAVE_GLIB=no])
PKG_CHECK_MODULES(GOBJECT, gobject-$with_glib >= 2.4, [HAVE_GOBJECT=yes], [HAVE_GOBJECT=no])
else # GLib path is explicitly defined
......@@ -317,8 +317,8 @@ else # GLib path is explicitly defined
fi # GLib path is explicitly defined
AM_CONDITIONAL([HAVE_GLIB], [test "x$HAVE_GLIB" != x])
AM_CONDITIONAL([HAVE_GOBJECT], [test "x$HAVE_GOBJECT" != x])
AM_CONDITIONAL([HAVE_GLIB], [test "x$HAVE_GLIB" = xyes])
AM_CONDITIONAL([HAVE_GOBJECT], [test "x$HAVE_GOBJECT" = xyes])
AC_SUBST(GLIB_LIBS)
AC_SUBST(GLIB_CFLAGS)
AC_SUBST(GLIB_VERSION)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment