config-ios: fix build for iOS9 and remove speex specific option, it is already...

config-ios: fix build for iOS9 and remove speex specific option, it is already done at the proper place
parent 6550fc65
......@@ -23,11 +23,5 @@
set(PLATFORM "OS")
include(configs/config-ios.cmake)
# Global configuration
set(LINPHONE_BUILDER_CPPFLAGS "${LINPHONE_BUILDER_CPPFLAGS} -mcpu=cortex-a8")
# speex
list(APPEND EP_speex_CMAKE_OPTIONS "-DENABLE_ARMV7_NEON_ASM=YES")
......@@ -71,6 +71,13 @@ unset(COMMON_FLAGS)
unset(CLANG_TARGET_SPECIFIER)
unset(SDK_VERSION)
#XCode7 requires Cmake 3.3.20150815 at least
if (NOT ${XCODE_VERSION} VERSION_LESS 7)
set (CMAKE_MIN_VERSION "3.3.20150815")
if (${CMAKE_VERSION} VERSION_LESS ${CMAKE_MIN_VERSION})
message(FATAL_ERROR "You need at least CMake version ${CMAKE_MIN_VERSION} but you are currently using ${CMAKE_VERSION}")
endif()
endif()
# Include builders
include(builders/CMakeLists.txt)
......
......@@ -58,6 +58,8 @@ set(IOS_TOOLCHAIN_RANLIB "${CMAKE_CURRENT_BINARY_DIR}/${IOS_TOOLCHAIN_HOST}-ranl
set(IOS_TOOLCHAIN_STRIP "${CMAKE_CURRENT_BINARY_DIR}/${IOS_TOOLCHAIN_HOST}-strip")
set(IOS_TOOLCHAIN_NM "${CMAKE_CURRENT_BINARY_DIR}/${IOS_TOOLCHAIN_HOST}-nm")
execute_process(COMMAND xcodebuild -version OUTPUT_VARIABLE XCODE_VERSION_RAW OUTPUT_STRIP_TRAILING_WHITESPACE)
STRING(REGEX REPLACE "Xcode ([^\n]*).*" "\\1" XCODE_VERSION "${XCODE_VERSION_RAW}")
include(CMakeForceCompiler)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment