Commit cfc9c915 authored by Ghislain MARY's avatar Ghislain MARY

Use last GCC version when building with bb10 toolchain.

parent 1ca78432
#!/bin/bash
ARGS=$*
source @BBNDK_ENV_SCRIPT@ && @BB10_TOOLCHAIN_PATH@-@TOOLNAME@ $ARGS
source @BBNDK_ENV_SCRIPT@ && @TOOLPATH@ $ARGS
......@@ -55,7 +55,14 @@ get_filename_component(COMPILER_NAME ${COMPILER_PATH} NAME)
string(REGEX REPLACE "-gcc$" "" BB10_TOOLCHAIN_PATH ${COMPILER_PATH})
string(REGEX REPLACE "-gcc$" "" BB10_TOOLCHAIN_HOST ${COMPILER_NAME})
foreach(TOOLNAME gcc g++ ld ar ranlib strip nm as)
foreach(TOOLNAME gcc g++)
file(GLOB TOOLPATH "${QNX_HOST}/usr/bin/${COMPILER_PREFIX}*-${TOOLNAME}-4*")
list(SORT TOOLPATH)
list(GET TOOLPATH -1 TOOLPATH)
configure_file(${CMAKE_CURRENT_LIST_DIR}/tool_wrapper.cmake ${CMAKE_CURRENT_BINARY_DIR}/${BB10_TOOLCHAIN_HOST}-${TOOLNAME})
endforeach(TOOLNAME)
foreach(TOOLNAME ld ar ranlib strip nm as)
set(TOOLPATH "${BB10_TOOLCHAIN_PATH}-${TOOLNAME}")
configure_file(${CMAKE_CURRENT_LIST_DIR}/tool_wrapper.cmake ${CMAKE_CURRENT_BINARY_DIR}/${BB10_TOOLCHAIN_HOST}-${TOOLNAME})
endforeach(TOOLNAME)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment