Commit e1540885 authored by Ghislain MARY's avatar Ghislain MARY

Use .md extension for all README files and use real markdown syntax.

parent eb55a423
********************************************************************
** LIBLINPHONE SDK FOR BLACKBERRY 10 USING LINPHONE CMAKE BUILDER **
********************************************************************
# LIBLINPHONE SDK FOR BLACKBERRY 10 USING LINPHONE CMAKE BUILDER #
BUILD PREREQUISITES
*******************
## BUILD PREREQUISITES
The common prerequisites listed in the README file are requested to build the
liblinphone SDK for BlackBerry 10.
......@@ -12,8 +9,7 @@ can get it from http://developer.blackberry.com/native/downloads/
Note that building the liblinphone SDK for BlackBerry 10 requires to be
building on a Linux or Mac OS X computer.
BUILDING THE SDK
****************
## BUILDING THE SDK
Run the following command after having setup the build prerequisites:
......@@ -25,8 +21,7 @@ It contains the header files, the built libraries and the resource files
for ARM and i486 (simulator) architectures needed to build a project based on
linphone.
OTHER COMMANDS
**************
## OTHER COMMANDS
You can clean the build tree (without deleting the downloaded source code) by
running:
......
********************************************************************
** FLEXISIP DEB AND RPM FILES **
********************************************************************
# FLEXISIP DEB AND RPM FILES #
BUILD PREREQUISITES
*******************
## BUILD PREREQUISITES
The common prerequisites listed in the README file are needed.
Note that building flexisip packages requires to be building on a Linux host.
......@@ -23,4 +20,3 @@ To be able to build Flexisip debs on a Debian machine, you will have to install
sudo aptitude install cmake rpm libmysqlclient-dev libmysql++-dev libmysqld-dev libssl-dev bison doxygen
sudo aptitude install alien fakeroot libhiredis-dev
make build-flexisip
\ No newline at end of file
****************************
** LINPHONE CMAKE BUILDER **
****************************
# LINPHONE CMAKE BUILDER #
Linphone CMake builder is a structure based on CMake to build linphone on
various platforms.
BUILD PREREQUISITES
*******************
## BUILD PREREQUISITES
The common prerequisites to use linphone-cmake-builder are:
- to intall CMake >= 2.8.12 (available in the package systems of Linux
- to intall CMake >= 2.8.12 (available in the package systems of Linux
distributions, in MacPorts for Mac OS X (http://www.macports.org/) and/or from
http://cmake.org/
- to install git (available in the package systems of Linux distributions, in
- to install git (available in the package systems of Linux distributions, in
MacPorts for Mac OS X (http://www.macports.org/) and/or from http://cmake.org/
AVAILABLE BUILD TARGETS
***********************
## AVAILABLE BUILD TARGETS
The following targets are supported:
- Linphone for BlackBerry10 - see README.bb10
- Liblinphone Python extension module - see README.python
- Flexisip and dependencies - see README.flexisip.md
\ No newline at end of file
- Linphone for BlackBerry10 - see README.bb10
- Liblinphone Python extension module - see README.python
- Flexisip and dependencies - see README.flexisip.md
\ No newline at end of file
********************************************************************
** LIBLINPHONE PYTHON EXTENSION MODULE **
********************************************************************
# LIBLINPHONE PYTHON EXTENSION MODULE #
BUILD PREREQUISITES
*******************
## BUILD PREREQUISITES
The common prerequisites listed in the README file are requested to build the
liblinphone Python extension module.
......@@ -11,42 +8,40 @@ You will also need to install some additional tools needed during the build
process. On linux, you can generally get them from your distribution. On Mac OS
X, you can get them from MacPorts. On Windows you will need to download and
install them manually. Here are these tools:
- A C and C++ compiler. On Windows you will need Visual Studio 2008 as it is
the version used by Python.
- Python 2.7.x, with 'pip' command. On windows, add c:\Python27\Scripts in the PATH.
- Java
- awk (automatically installed when building on Windows)
- sed (automatically installed when building on Windows)
- patch (automatically installed when building on Windows)
- yasm (automatically installed when building on Windows)
- xxd (only for Linux and Mac OS X)
- pkg-config (automatically installed when building on Windows)
- intltoolize (automatically installed when building on Windows)
- doxygen
- dot (graphviz)
- pystache (install with pip install pystache in terminal)
- wheel (install with pip install wheel in terminal)
- MinGw (only on Windows): Follow the instructions at http://mingw.org/wiki/Getting_Started
- A C and C++ compiler. On Windows you will need Visual Studio 2008 as it is
the version used by Python.
- Python 2.7.x, with 'pip' command. On windows, add c:\Python27\Scripts in the PATH.
- Java
- awk (automatically installed when building on Windows)
- sed (automatically installed when building on Windows)
- patch (automatically installed when building on Windows)
- yasm (automatically installed when building on Windows)
- xxd (only for Linux and Mac OS X)
- pkg-config (automatically installed when building on Windows)
- intltoolize (automatically installed when building on Windows)
- doxygen
- dot (graphviz)
- pystache (install with pip install pystache in terminal)
- wheel (install with pip install wheel in terminal)
- MinGw (only on Windows): Follow the instructions at http://mingw.org/wiki/Getting_Started
On windows, append the following to your PATH if not the case:
c:\Program Files (x86)\GnuWin32\bin
c:\MinGW\bin
c:\Python27\Scripts
C:\Program Files (x86)\Graphviz2.38
C:\Program Files (x86)\GnuWin32\bin
C:\MinGW\bin
C:\Python27\Scripts
C:\Program Files (x86)\Graphviz2.38
Once done, within the system's shell (unix terminal, windows cmd), place into
the root of linphone-cmake-builder project and run the following commands:
BUILDING THE SDK ON LINUX AND MAC OS X
**************************************
## BUILDING THE SDK ON LINUX AND MAC OS X
$ make build-python -- -DCMAKE_BUILD_TYPE=Release
If everything is successful (and after a few minutes) you will find the Python
wheel package of the liblinphone Python extension module in the OUTPUT directory.
BUILDING THE SDK ON WINDOWS
***************************
## BUILDING THE SDK ON WINDOWS
Run the following command in Windows command prompt after having setup the build prerequisites:
......@@ -55,4 +50,3 @@ Run the following command in Windows command prompt after having setup the build
If everything is successful (and after a few minutes) you will find the Python
wheel package and installers of the liblinphone Python extension module in the
OUTPUT directory.
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment