Commit f5f23194 authored by François Grisez's avatar François Grisez

Update README.macosx about libvpx

* Remove libvpx from packages installed with MacPort
* Add a procedure to build libvpx
parent 8964ec08
......@@ -24,7 +24,7 @@ In order to enable generation of bundle for older MacOS version, it is recommend
##### Linphone library (liblinphone)
sudo port install automake autoconf libtool pkgconfig intltool wget cunit \
antlr3 speex libvpx readline sqlite3 openldap libupnp \
antlr3 speex readline sqlite3 openldap libupnp \
ffmpeg-devel -gpl2
##### Linphone UI (GTK version)
......@@ -77,6 +77,26 @@ The next pieces need to be compiled manually.
./autogen.sh && ./configure --prefix=/opt/local && make
sudo make install
* Install libvpx (Must be manualy build because the macport recipe does not support 'macosx_deployment_target')
git clone https://chromium.googlesource.com/webm/libvpx -b v1.3.0
cd libvpx
./configure --prefix=/opt/local \
--enable-error-concealment \
--enable-multithread \
--enable-realtime-only \
--enable-spatial-resampling \
--enable-vp8 \
--disable-vp9 \
--enable-libs \
--disable-install-docs \
--disable-debug-libs \
--disable-examples \
--disable-unit-tests \
--as=yasm
make
sudo make install
* Install belle-sip (sip stack)
git clone git://git.linphone.org/belle-sip.git
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment